混合モードアセンブリはバージョンのランタイムに対して作成されており、追加の構成情報がないと 4.0 ランタイムでは読み込めません。

SlimDXを使おうとしても

 Message=混合モード アセンブリはバージョン 'v2.0.50727' のランタイムに対して作成されており、
追加の構成情報がないと 4.0 ランタイムでは読み込めません。
とのエラー
これはapp.configに以下の<startup>の部分を追加することで解決できた。

<configuration>
  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0"/>
  </startup>
</configuration>

LuaInterfaceを使おうとしたときにも発生した。
Post a comment or leave a trackback: Trackback URL.

Comments

  • bellyoshi  On 2014年10月4日 at 6:05 PM

    ちなみにapp.configがプロジェクトにない場合はプロジェクトを右クリック
    →プロパティ→設定で
    アプリケーション設定が何も追加されていないので
    新規行をクリックするとapp.configが追加される。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です